HQ NETWORK:   XBOX ONE |  XBOX 360 |  AIDELUXE HQ Network: 1,631 | Guests: 317 | Members: 3 


   Current Location: Forums Where are the websites listing the files you can delete from   |   Hello everyone   |   Installing a new Dashboard on an Chip modded XBox   |   error 5 on xbox   |   HELP! replacement motherboard with XECUTER 2 BIOS   |   1.2 Board spitting Christmas lights   |   new member   |   Seagate Momentus XT   |   MY PROFILE -> MY GAMES now available on XBOX-HQ!   |   About to give up on chimp   |   
  Home | Active Topics | CD/DVD Media | Downloads | Forums | Feedback | Games | HardDrives | Homebrew | My Profile | ModChips | Reviews | Search | SoftMods | Tutorials

Xbox Forums

Discuss all aspects of the original Xbox Console in our Interactive Xbox Forums..

Pre-order Microsoft Flight Simulator
Xbox-Hq.Com :: View topic - Softmodded v1.0 Xbox Hdd Problems
Xbox-Hq.Com Forum Index -> Xbox SoftMod Discussions
Post new topic Reply to topic    
 Softmodded v1.0 Xbox Hdd Problems View previous topic :: View next topic  
 
 
 
 
sdb6607
Xbox-HQ Newbie
Xbox-HQ Newbie



Joined: Jan 20, 2014
Posts: 4

Post Posted: Sun Feb 02, 2014 5:23 am   
Post subject: Softmodded v1.0 Xbox Hdd Problems
Reply with quote
 
Okay just started messing around with my old xbox recently and after acquiring an old pc i was able to softmod the original HDD with Ndure. Worked great. Installed Unleash X dashboard. Backed up C drive and Eeprom successfully.
From this point i wanted to upgrade the HDD since i have a bunch of Xbox game files i wanted to be able to load them onto the xbox and take it where i please.

So purchased a sata to ide adapter from newegg and attempted to use two different Sata HDDs i had laying around. Couldn't get either of them to work with xboxhdm. They processed correctly but ultimately the xbox wouldnt boot. So i settled for a 120g IDE HDD from the old computer. Worked flawlessly but i quickly filled the HDD and didnt have the variety that i really wanted. Purchased a different Sata to Ide adapter and was able to clone the 120g HDD (btw that took forever) to a WD 250 sata drive (the 1.5tb drive i had was bricked. Bad clusters and whatnot) After 2.5 days running chimp it was finished!

Locked the drive, switched the cables back. Put the jumper to master... and SUCCESS! SO..... then why am i posting. Well about 2 hrs after i rebooted the new HDD successfully i was going to ftp files over and all of a sudden... Flashing Red/Green. WTF... my xbox doesn't give error codes must be too old but i figured the problem. I reconnected the drive and booted chimp again. Unlocked and locked the sata hard drive. Shut down. Swapped all the cables and boom. Boots perfectly. An hour later. Flashing red/green.

Now i dont know what to do. Im waiting on a 2tb HDD in the mail and i want to know how to fix this. Is TSOP right for me? I cant find a definite answer. Hopefully someone here can help.

Thanks in advance.


View user's profile Send private message
 
 
 
 
KenM-64
V.I.P. Lifetime


Joined: Nov 06, 2013
Posts: 131

Post Posted: Sun Feb 02, 2014 6:06 am   
Post subject:
Reply with quote
 
You must make sure your Sata to IDE adapter also has Master & Cable Select settings.
The Xbox requires C/S setting for the HDD.

Was the 1.5TB HDD completely dead,
You may be able to revive that drive by low level formatting it with a dos boot disc, and reuse it on your Xbox.

The old computer you were using,
was it an Intel chip-set,
If it is Intel chip, Set HDD detection to none and set your IDE adapter to Master and try building hard-drive from scratch with your eeprom.bin
lock the HDD set IDE adapter to C/S and put it in yer box.


View user's profile Send private message
 
 
 
 
sdb6607
Xbox-HQ Newbie
Xbox-HQ Newbie



Joined: Jan 20, 2014
Posts: 4

Post Posted: Sun Feb 02, 2014 6:28 am   
Post subject:
Reply with quote
 
I tried switching the jumper to C/S but no luck. It worked fine after relocking the drive but eventually doesn't work anymore.

the 1.5tb was a seagate and seatools said it was trashed even after using linux to rewrite the whole drive to zeros.

Slightly confused about the intel question. I was able to get xboxhdm to pickup the sata drives with both adapters and the process was successful according to xboxhdm but they would never boot in the xbox. I always just waited till the xboxhdm screen before attaching the hdd cause the bios would freeze them. (im assuming this is why your saying to set the bios to not discover the hdds)

I can get the 250g sata drive to work again. I just have to unlock and relock it. In chimp when i look at drive status it says yes, yes, yes, no, no, high. But it just keeps failing eventually


View user's profile Send private message
 
 
 
 
KenM-64
V.I.P. Lifetime


Joined: Nov 06, 2013
Posts: 131

Post Posted: Sun Feb 02, 2014 7:29 am   
Post subject:
Reply with quote
 
sdb6607 wrote:

Slightly confused about the intel question. I was able to get xboxhdm to pickup the sata drives with both adapters and the process was successful according to xboxhdm but they would never boot in the xbox. I always just waited till the xboxhdm screen before attaching the hdd cause the bios would freeze them. (im assuming this is why your saying to set the bios to not discover the hdds)

"Intel question" Yes that is what i was saying HDD frozen.
If you put HDD in Xbox and will not boot,
you now have the softmod on the HDD and will read DVD-r's & boot installer disc's.
Try cold booting an installer disc in the DVD drive like Babylon or AID etc
and install your dashboard.

The 1.5TB would not be that old.
I had problems with HDD's,
I removed the pcb from the drive and cleaned the contacts on HDD and pcb with a pencil eraser and put HDD back together was able to format it
and reuse it in the Xbox.


View user's profile Send private message
 
 
 
 
Heimdall
Xbox-HQ User
Xbox-HQ User

Xbox Version: 1.4
Modded:

Joined: Mar 14, 2013
Posts: 11

Post Posted: Sun Feb 02, 2014 12:10 pm   
Post subject:
Reply with quote
 
For the 1.5TB HDD a "DOS disk reformat" will make precisely no difference, and neither will zeroing the disk with linux. Get a copy of HDAT2 (you can find it on Hiren's Boot CD) and run HDAT2 on the drive. Select "Device Test Menu - Check and repair bad sectors" or "Most powerful test". That will test every sector on the surface of the hard drive, and update the G-List (the list of bad sectors held in the disc microcontroller) so that any bad sectors are marked as unusable. It takes some time, but for drives with a few bad sectors / clusters it works well. Note that if you get hundreds of errors then it's likely that the drive is probably at the end of its useful life.

The Intel chipset thing is a red herring in this case. If xboxhdm sees and locks the drive then it isn't frozen, and the fact that the drive boots at least once in the Xbox confirms that. The problem isn't the drive, or the machine you use to build it - it's the Xbox, or the IDE-SATA adapter, or the IDE cable.

Some people report that replacing the IDE cable with an 80 conductor version improves boot stability with SATA drives. It's probably worth a try.


Last edited by Heimdall on Sun Feb 02, 2014 8:49 pm; edited 1 time in total


View user's profile Send private message
 
 
 
 
sdb6607
Xbox-HQ Newbie
Xbox-HQ Newbie

Xbox Version: 1.4
Modded:

Joined: Jan 20, 2014
Posts: 4

Post Posted: Sun Feb 02, 2014 6:59 pm   
Post subject:
Reply with quote
 
Heimdall you nailed it. When kenm-64 started saying about Cable select i started wondering. So i removed the original cable, tossed in a Cable Select cable and magically it booted without any issue and very quickly at that. I left the xbox unplugged overnight and this morning i tested it again. Worked like a charm. Now i just need to find some way of making everything fit back inside. Might have to look for a different length cable select cable.

Also i even tested my original sata-ide connector that i paid about 3 dollars for on newegg that doesn't have jumpers and it works just fine. Slower to boot but it still works.

Thanks guys.


EDIT: I tried modifying one of the cable select cables that i had but it stuttered on loading the bios and eventually failed. In searching around the internet i saw posts about using a standard IDE cable select cable in reverse. Using the motherboard end for the HDD, the slave end for the DVD and the master end for the motherboard. Boots to unleashX perfectly. Ill update again if it stops working.


View user's profile Send private message
 
 
 
 
KenM-64
V.I.P. Lifetime


Joined: Nov 06, 2013
Posts: 131

Post Posted: Mon Feb 03, 2014 12:59 am   
Post subject:
Reply with quote
 
Thanks Heimdall
Hiren's dos Boot disc is what i have and use to fix my drive's.
Heap's of software on it for lots of things.

@ sdb6607
The jumper setting on the device(HDD) must be set to C/S to be a HDD for an Xbox and the DVD drive to Slave.
A cable does not select Master, Slave or Cable select, a jumper does.

The Sata adapter you are getting does it have
JMicron 20330 chipset
The datasheet for the jumper setting says Master/Slave support only, no cable select.
C/S is not an option for JM20330 Sata adapters.

SunPlus SPIF223A chipset has all three settings.


Last edited by KenM-64 on Mon Feb 03, 2014 3:01 am; edited 1 time in total


View user's profile Send private message
 
 
 
 
sdb6607
Xbox-HQ Newbie
Xbox-HQ Newbie

Xbox Version: 1.4
Modded:

Joined: Jan 20, 2014
Posts: 4

Post Posted: Mon Feb 03, 2014 3:00 am   
Post subject:
Reply with quote
 
I have this adapter Startech that has a jumper CS/M/SL on it though like i said im not using a jumper on it with the Cable Select Cable.

And this adapter also from Newegg

They're both working with the Cable select cable run backwards but would not work with the original Xbox IDE Cable.

once Hirens finishes running i will try building with hdm again and see if it works.


View user's profile Send private message
 
 
 
 
KenM-64
V.I.P. Lifetime


Joined: Nov 06, 2013
Posts: 131

Post Posted: Mon Feb 03, 2014 3:15 am   
Post subject:
Reply with quote
 
With 1.5TB will take a long time to do.
Your old cable must have been faulty anyway to not work.
Your new cable has a slot cut for C/S in it must be around the right way to work right.
Blue plug to motherboard,Grey to Slave(DVD),Black to Master(HDD).
I make these to size to suit my Xbox.
80 conductor cable & plugs, Blue, Grey, Black,


View user's profile Send private message
 
Display posts from previous:   
  Post new topic  
 
  Reply to topic  
|
 All times are GMT | Page 1 of 1
Jump to:  
 

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum
 

 Members Online (3) / Guests Online (317)
Members Browsing
beckermorse2, doa666, xxxbennybear,

Legend
Administrator  Moderator  VIP Member  Registered User  Banned Users

McAfee US